CVE-2018-3760
Publication date 26 June 2018
Last updated 3 November 2026
Ubuntu priority
Cvss 3 Severity Score
Description
There is an information leak vulnerability in Sprockets. Versions Affected: 4.0.0.beta7 and lower, 3.7.1 and lower, 2.12.4 and lower. Specially crafted requests can be used to access files that exists on the filesystem that is outside an application's root directory, when the Sprockets server is used in production. All users running an affected release should either upgrade or use one of the work arounds immediately.
Status
| Package | Ubuntu Release | Status |
|---|---|---|
| ruby-sprockets | 26.10 stonking |
Not affected
|
| 26.04 LTS resolute |
Not affected
|
|
| 24.04 LTS noble |
Not affected
|
|
| 22.04 LTS jammy |
Not affected
|
|
| 20.04 LTS focal |
Not affected
|
|
| 18.04 LTS bionic |
Fixed in 3.7.0-1+deb9u1build0.18.04.1
|
|
| 16.04 LTS xenial |
Fixed in 3.3.0-1ubuntu0.1~esm1
|
|
| 14.04 LTS trusty | Not in release |
Severity score breakdown
CVSS version: CVSS v3.0
Base score
7.5 · High
Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
References
Related Ubuntu Security Notices (USN)
- USN-8990-1
- Sprockets vulnerability
- 3 November 2026